[clug-talk] Can't boot to kde or gnome

Richard Carter carter.r.a.l at gmail.com
Tue Oct 2 09:32:23 PDT 2007


Mark,

Thanks for your help.  Here is what happened.

If I login as robin the mail contains 137 messages all saying that backup21
needs to have a file configured.  I don't use that program anymore so those
aren't interesting.  When I login as root there aren't any messages.

I tried to login to TWN, Twn and Failsafe from the display manager (?)
screen but in each case it just returns to itself.

I found xsession-erriors: it's empty.

I can't find a file named .xinitrc in / or in /home/robin

There are two other things which may be helpful.  First,  when I'm logged in
a console if I don't type anything for a short time lines beginning with
"DROPPED IN=eth0 OUT=MAC=ff:ff:ff:ff:ff:ff: " appear many times on the
screen.  This happens both when I'm logged in as root and as robin.  Second,
I have tar balls of /etc, /usr/local and /var (minus /var/cache, var/spool,
/var/tmp) created just before the problem arose. But the tar ball of robin
was created after the problem began when I found I could log in and use
gnome.

I would appreciate any help.

Robin

On 10/1/07, Mark Carlson <carlsonmark at gmail.com> wrote:
>
> On 9/30/07, Richard Carter <carter.r.a.l at gmail.com> wrote:
> <snip>
> > However, if I choose "Console Login'" from the Menu tab login.succeedsand I
> > get a message "You have new mail", which I don't understand.
> <snip>
>
>
> "You have new mail" when you log in as root: this generally means that
> your system has been running cron-jobs as root (often security-related
> jobs such as checking for UID/GID changes, disk usage, etc.)  To read
> them, use the 'mail' command.  At the mail prompt, (&), use 'n' to
> read each message if you would like to.  I use a .forward file in the
> /root directory to send these messages to an email account I actually
> use.  It can be nice for boxes you don't look at often, to see if the
> disk is filling up, or if there have been any ssh brute-force attacks,
> etc.
>
>
> On 10/1/07, Richard Carter <carter.r.a.l at gmail.com> wrote:
> > Szemir; After I log in as root, startx starts the gnome desk top!!!  But
> if
> > I enter startx as robin lines from /var/log/Xorg.0.log (I think) are
> > displayed none of which begin with EE although one line did say that the
> > kernel was disabling IRQ #201.   Using find I couldn't find a file
> called
> > xsessions-errors.
>
> The file is named .xession-errors, and it is usually in the home
> directory of your user (/home/user/.xsession-errors)
> 'locate' is often more helpful than 'find' for finding files, if it is
> installed, that is
>
> > Gustin:  I checked gdm.log and kde.log but I couldn't see any thing that
>
> > looked l like an error.  Xorg.0.log contained some warnings about
> missing
> > fonts, the mode of the clock and the fact that AIGLX: 30 driver doesn't
> > support some visuals but nothing beginning with EE  I also checked
> > /var/messages.  This is a very big file most of which looked innocent
> > although it did say that a message handler couldn't be found and that
> there
> > was a bad irq.
> >
> > The problem with all this is that I don't really know what to look for
> in
> > all these log files so I may well have missed something important.  I
> wonder
> > of the problem is that the kde login manager is corrupted?
> >
> > Any further suggestions?
>
> Try a more basic window manager, such as twm.  If your display manager
> (where you are logging in from) is returning to itself, it is because
> whatever it tried to run failed to do so.  This is what happens when
> you use ctrl-alt-backspace to exit from kde/gnome.  So what you need
> to do is find out what is causing it to fail.  This could be in the
> xorg log or .xsession-errors.  It is usually easier to log in to the
> console as your user, run startx, and go from there.
>
> See if there is a /home/username/.xinitrc file and report back with
> its contents.
>
> This is the #2 reason I don't use a display manager if I can help it.
> Just one more thing to break.  (#1 reason being it makes it difficult
> to use other ttys in some circumstances.)
>
> -Mark C.
>
> _______________________________________________
> clug-talk mailing list
> clug-talk at clug.ca
> http://clug.ca/mailman/listinfo/clug-talk_clug.ca
> Mailing List Guidelines (http://clug.ca/ml_guidelines.php)
> **Please remove these lines when replying
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://clug.ca/pipermail/clug-talk_clug.ca/attachments/20071002/9532f55c/attachment.html 


More information about the clug-talk mailing list