[clug-talk] apt-get upgrade

Michael Walters waltersm at telusplanet.net
Sat May 13 21:09:18 PDT 2006


Hello Gustin,

When I do a vi <filename> command I can now see the filename after the 
insert command due one of the suggestions that worked.

I still do not have aspell, but I can try again another day. And nothing 
  else seems to have been broken in the process. So my system has had an 
improvement.

Thanks for everyone's help.

Michael


Gustin Johnson wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> You will probably want to run sudo apt-get update first, so that the
> database of packages on your computer is up to date.  Then run sudo
> apt-get upgrade.
> 
> If that does not clear all errors then try sudo apt-get dist-upgrade.
> 
> The short explanation is that the last command is used if your install
> is quite old.
> 
> Cheers,
> 
> Michael Walters wrote:
> 
>>Hello all,
>>
>>I did a man apt-get and found that there was an option called apt-get 
>>upgrade, so I decided to try apt-get upgrade.
>>
>>Since I did not know what would happen, I was afraid I might mess up my 
>>system, but I decided to try it any way.
>>
>>I found that I needed to run as root, so I su'd to root and ran apt-get 
>>upgrade, and to my surprise, it seemed to work.
>>
>>After running for a while ( I decided to leave the computer running on 
>>apt-get upgrade) there were  some error messages, but nothing serious 
>>seemed to go wrong, so I decided to try out some things that might have 
>>worked better if something worked.
>>
>>I tried the command aspell -c agenda20060513 which I did with tab 
>>completion, until I got the full file name, and still got the same error 
>>message that there were no word lists for us .
>>
>>So apparently apt-get upgrade did not break my system nor did it seem to 
>>do anything positive for my system.
>>
>>I still want to get a binary stand alone program to spell check files 
>>created under the vim editor and would also like to configure the vim 
>>editor to keep the name of the file on the top of the screen when 
>>editing a file within the screen which I used to be able to do at one 
>>time. But now whenever I do a vi <filename> and then i for insert, the 
>>file name completely disappears.
>>
>>Do any of you have suggestions as to how to download and install 
>>aspell.bin and how to configure vim editor to keep the file name visible 
>>on part of the screen? I did manage to configure the vim editor to line 
>>wrap successfully. If I can do the other two items I would have the vim 
>>editor fully configured for my purposes.
>>
>>Even with the vim editor as it is now I can edit .c files and can check 
>>the c programs thus created and check their syntax and get simple c 
>>programs working. And the vim editor does this by color coding the 
>>characters on the screen in an intelligible way which gives me clues as 
>>to what to do to edit the programs to make them work. And I can use the 
>>first book on c programming that I got from my cousin to do the rest.
>>
>>regards,
>>
>>Michael Walters
>>
>>_______________________________________________



More information about the clug-talk mailing list