[clug-talk] TV-Out - I hope you like text

Gustin Johnson gustin at echostar.ca
Wed May 10 17:12:20 PDT 2006


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

There are two approaches, I used the second one personally.

First make sure that you have this in /etc/apt/sources.list

# Ubuntu backports project (packages, GPG key: 437D05B5)
deb http://archive.ubuntu.com/ubuntu breezy-backports main restricted
universe multiverse

Then run:
aptitude update

Then try the apt-get line again.

I did not follow the guide on the ubuntu forums, but this is because I
tend to have a fairly recent kernel installed and thus tend to need
recent versions of the driver.

First download the latest driver (as of right now anyway) from the
nvidia website
wget
http://download.nvidia.com/XFree86/Linux-x86/1.0-8756/NVIDIA-Linux-x86-1.0-8756-pkg1.run

Make sure you have the kernel headers installed, a simple aptitude
install kernel-headers should suffice.

Then run the resulting downloaded .run file, like this:
sudo ./NVIDIA-Linux-x86-1.0-8756-pkg1.run -a

It should step you through what it needs to do.  I believe that latest
version also sets up your xorg.conf, but don't quote me on that.

After a reboot you should be good to go (well, you don't need to reboot,
modprobe nvidia and then /etc/init.d/gdm restart or /etc/init.d/kdm
restart depending on which you are using, gdm=Ubuntu kdm=Kubuntu)

The box that has my 5600 is currently running headless, so I didn't test
these instructions (the box didn't lock, but I have no idea if the TV
out works)

Mike Bougie wrote:
> Hey everyone,
> 
> In true Mike fashion, I think I've pooched my xorg.conf file pretty
> decently. I'm trying to get my Nvidia Fx5200's TV-Out feature to work
> properly, and in doing so I used this guide, found on
> 
> http://ubuntuforums.org/showthread.php?t=98456&highlight=fx5200
> 
> now when I reboot, I get no GUI, and after logging in and doing a
> "startx" the screen blanks as if x is loading, but then I get 
> redicrected to command line with an error that reads as follows (among 
> other information):
> 
> Using config file "/etc/X11/xorg.conf"
> Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o" 
> : No symbols found
> 
> Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o" 
> : No symbols found
> 
> Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o" 
> : No symbols found
> 
> (EE) Failed to load module "Record" (module does not exist,0)
> (EE) Failed to load module "nvidia" (module does not exist,0)
> (EE) No drivers available.
> 
> Fatal server error:
> no screens found
> 
> Now, I've also followed thes einstructions to update with the latest 
> nvidia drivers
> 
> http://ubuntuforums.org/showthread.php?t=75074
> 
> but when I try to
> 
> sudo apt-get install nvidia-glx nvidia-settings 
> linux-restricted-modules-`uname -r`
> 
> I get E: couldn't find package linux-restricted-modules
> 
> Any ideas how I can get this module loaded so I can load "Record" and 
> "nvidia" then finally get the TVOut working on my Fx5200?
> 
> ~Mike
> 
> P.S. I had to write all that mumbo-jumbo since the errors are on another 
> machine, so forgive me if there are the occasional spelling errors 
> (which I doubt) or mis-types (entirely possible).
> 
> ~Mike
> 
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFEYoFkwRXgH3rKGfMRAnzRAKCAmieBk9a+l7xePMtKXpmJPr45wQCeIRox
PRTsFEyvKXl9g7JNPC2vwBQ=
=A1wm
-----END PGP SIGNATURE-----



More information about the clug-talk mailing list