[clug-talk] serial console help

Shawn sgrover at open2space.com
Sun Sep 25 23:33:50 PDT 2005


I seem to remember back in the serial modem days, that you had to specify a 
bps to use, as well as whether Xoff (hardware handshake) was on or off.  
Also, I wrote a program once utilizing a serial connection to a hardware 
device - I most definetly had to slow the bps down to 2400 or the thing went 
kaput.  

The message you are seeing indicating too much work seems to suggest you are 
passing more bps than the virtual serial console can take.  You say you have 
tried 9600 to 115200 - but these are on the high end.  My experience suggests 
starting with 2400.  (if it's text based 2400bps won't affect things tooooo 
much.)

HTH

Shawn

On Sunday 25 September 2005 23:50, Gustin Johnson wrote:
> I am running a qemu session with -nographic which means that there is no
> graphic output.  Control of the VM occurs across a virtual serial
> connection (/dev/ttyS0 to the guest, and either stdio or a pty on the
> host).  The problem is when I run vim somefile I get some garbled
> characters and the following sprayed across much of the screen:
> serial8250: too much work for irq4
>
> I have not had much experience with serial consoles (except as a user of
> the UofC's DevlNET, which I kinda miss), so any help would be appreciated.
>
> The output of setserial:
> setserial -g /dev/ttyS*
> /dev/ttyS0, UART: 16450, Port: 0x03f8, IRQ: 4
>
> I have also played with various rate (aka speed) settings from 9600 to
> 115200
>
> I have not pleased the google gods with the correct prayer incantation.
> I have also been to:
> http://www.faqs.org/docs/Linux-HOWTO/Serial-HOWTO.html
>
> The entry I have in /etc/inittab is
> S0:123456:respawn:/sbin/mgetty -x1 -b -r -s 38400 ttyS0
>
> and in /boot/grub/menu.lst
>
> # Serial console setup
> serial --unit=0 --speed=38400
>
> # now setup terminal as both serial line (/dev/ttyS0) and regular monitor
> # console (/dev/tty0) depending on where you press a key
> terminal --timeout=15 serial console
>
> and the kernel option:
> console=ttyS0
>
> Of course when using ssh to connect everything works as expected.
>
> Id should also be noted that regular console use appears to work normally
> (copying, moving, running ifconfig, ip route etc).
>
> Thanks in advance.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://clug.ca/pipermail/clug-talk_clug.ca/attachments/20050926/e37857da/attachment-0001.bin


More information about the clug-talk mailing list