[clug-talk] Reset root password SuSE 9.2

Gustin Johnson gustin at echostar.ca
Sun Sep 11 04:41:32 PDT 2005


3.4 _is_ fairly old in the knoppix world.

Anyway, the simplest method I have found is to mount the drive with 
knoppix (or
any live CD that supports reiser, which should be most of them), then edit the
/etc/shadow file, replacing the password hash with the hash of a know 
password.
I often use e10adc3949ba59abbe56e057f20f883e which is 123456.  Reboot, login,
and run passwd.

Of course chroot works as well.
-- 
No trees were harmed in the transmission of this message, however a 
large number
of electrons were seriously inconvenienced.


Quoting Jarrod Major <jmajor at nucleus.com>:

> Hey Gang,
>
> I've been beating my head against a wall here for hours. I have a server that
> I haven't yet put into production (it's only been on my local network) and I
> haven't touched it for months. When i went to login, it appears that I have
> forgotten my root and user passwords. Nothing I enter works anyway. I usually
> write these things down, must've slipped my mind this time.
>
> I have the original install media so I did a Google search and the 
> easiest way
> appears to fire in Disc 1 and select Rescue system from the boot menu. They
> talk about editing the /etc/passwd and /etc/shadow files. I have done this
> and when I reboot, I still can't get in as root. Effectively, they suggest
> you clear out the root password so that when you reboot, there is no
> password, you are supposed to just hit enter. When I hit enter at the root
> login prompt I get "Login incorrect".
>
> I tried Tom's Root Boot disc but unfortunately it doesn't support the Reiser
> FS and my / partition (where /etc lives, no d'uh!) is Reiser.
>
> I have a Knoppix disc but I didn't make it and for whatever reason this
> particular system doesn't want to boot from this CD (the SuSE 9.2 disc one is
> also burned and boots fine). I didn't want to do a big ISO download for the
> latest Knoppix, this one isn't that old... 3.4
>
> So I am running out of options here. There was other advice to physically
> remove the drive and install it in a working system and once mounted edit the
> same files. I don't want to resort to this and it almost seems like they are
> getting reset somehow. Is Reiser doing this? Is this a funky SuSE thing? I
> read docs right off the SuSE site regarding the rescue procedure so I am
> confident they are supposed to be right.
>
> This is a basic install, no GUI, just the OS and Apache and a few other
> things.
>
> I'm not having much luck with root passwords these days. First my laptop and
> now this (I haven't tried my user password for root in Kubuntu Neil, I will).
>
> Going to bed, gonna try this again tomorrow. TIA!
> --
> Jarrod Major
> GPG Fingerprint: 4556 EFA8 EC69 7C54 EE33  C881 2C7C 0E10 2439 231E
>



---------------------------------------------------
This message was sent using Echostar Secure Webmail

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: PGP Digital Signature
Url : /pipermail/clug-talk_clug.ca/attachments/20050911/b2a355f1/attachment.bin


More information about the clug-talk mailing list