[clug-talk] Reset root password SuSE 9.2

Mel Walters titus1 at telus.net
Sat Sep 10 10:43:26 PDT 2005


On Fri, 2005-09-09 at 23:24 -0600, Jarrod Major wrote:
> Hey Gang,
> 
> I've been beating my head against a wall here for hours. I have a server that 
> I haven't yet put into production (it's only been on my local network) and I 
> haven't touched it for months. When i went to login, it appears that I have 
> forgotten my root and user passwords. Nothing I enter works anyway. I usually 
> write these things down, must've slipped my mind this time.
> 
> I have the original install media so I did a Google search and the easiest way 
> appears to fire in Disc 1 and select Rescue system from the boot menu. They 
> talk about editing the /etc/passwd and /etc/shadow files. I have done this 
> and when I reboot, I still can't get in as root. Effectively, they suggest 

I remember doing this and got my root password reset. I am not very sure
of what you meant by clear out the root password.
If you left the line en-tact, taking away password info so you have
(in /etc/shadow  root:::::::: left, this is how I remember doing it. 
Make sure you change the password immediately.
I know you did it this way, but someone new to Linux may take the words
effectively clear the root password as removing the line. This would not
work. Then you could go back to the copy (backup) file you made.

OR you could do something like this:

boot from live CD

mkdir /mnt/SuSE

mount /dev/hda /mnt/SuSE
chroot /mnt/SuSE /bin/bash
passwd

Mel

Disclaimer: This is mostly by memory, and some quick look ups
(It just MAY work:)

> you clear out the root password so that when you reboot, there is no 
> password, you are supposed to just hit enter. When I hit enter at the root 
> login prompt I get "Login incorrect".
> 
> I tried Tom's Root Boot disc but unfortunately it doesn't support the Reiser 
> FS and my / partition (where /etc lives, no d'uh!) is Reiser.
> 
> I have a Knoppix disc but I didn't make it and for whatever reason this 
> particular system doesn't want to boot from this CD (the SuSE 9.2 disc one is 
> also burned and boots fine). I didn't want to do a big ISO download for the 
> latest Knoppix, this one isn't that old... 3.4
> 
> So I am running out of options here. There was other advice to physically 
> remove the drive and install it in a working system and once mounted edit the 
> same files. I don't want to resort to this and it almost seems like they are 
> getting reset somehow. Is Reiser doing this? Is this a funky SuSE thing? I 
> read docs right off the SuSE site regarding the rescue procedure so I am 
> confident they are supposed to be right.
> 
> This is a basic install, no GUI, just the OS and Apache and a few other 
> things.
> 
> I'm not having much luck with root passwords these days. First my laptop and 
> now this (I haven't tried my user password for root in Kubuntu Neil, I will).
> 
> Going to bed, gonna try this again tomorrow. TIA!
> _______________________________________________
> clug-talk mailing list
> clug-talk at clug.ca
> http://clug.ca/mailman/listinfo/clug-talk_clug.ca
> Mailing List Guidelines (http://clug.ca/ml_guidelines.php)
> **Please remove these lines when replying




More information about the clug-talk mailing list