[clug-talk] Shut off the 'tap' on my touchpad.

Jon me at jonwatson.ca
Sat Sep 3 13:25:14 PDT 2005


Hi Dave,

Thanks for the reply.

I do indeed use a USB mouse and then, as you've experienced, I can use both 
the touchpad and the USB mouse at once.

I guess you missed the very first post of this thread. My problem is that I 
only want to disable the 'tap' functionality of my touchpad. I need all the 
other functionality for when I am sitting out on the deck or somewhere else 
that isn't conducive to using a mouse, but the 'tap' functionality of my 
touchpad is driving me nuts. It's waaay to sensitive. Whenever I touch the 
pad at all it thinks I'm tapping and if the pointer happens to be over a 
button or a web page link, it clicks it.

None of the touchpad controls in KDE Control center, or manually changing them 
in my XF86Config-4 make any difference whatsoever. This is why I think my 
tochpad is emulating a mouse.

However, since there's no 'tap' option for a mouse...there's no way to shut it 
off that I can see.

The BIOS is no help either...it has no options of any use in it.

Jon

On September 3, 2005 05:54 pm, Dave Bourassa wrote:
> Domain match.
> Remove domain from Allow list -->
>  
> https://www.vqme.com/pk/eh?op=remove_domain&Domain=clug.ca&VU=HqIXF6rk+PpDI
>0Rq/fWFgg Block domain -->
>  
> https://www.vqme.com/pk/eh?op=block_domain&Domain=clug.ca&VU=HqIXF6rk+PpDI0
>Rq/fWFgg
>
> Jon wrote:
> > Thanks Graham,
> >
> > I tried the Synaptics driver and followed the install isntructions, but
> > to no avail. No errors or anything, just no change in behaviour.
> >
> > I almost think that my touchpad is emulating a mouse somehow and that
> > XF86 is unaware that it's a touchpad. I think this because shutting the
> > touchpad off altogether in the KDE Control Centre has no effect and my
> > XF86Config-4 file actually says in it 'No Synpatics touchpad detected'
> > and 'ALSP Touchpad not detected'.
> >
> > Very frustrating...
> >
> > Jon
>
> -- snipped a bunch...
>
> Your touch pad, if it's anything like my panasonic tough book, is indeed
> emulating a mouse.  Probably a ps2 one, specifically.  When I first got
> my tough book, I found that the touch pad (tp) was not my favorite input
> device, so I looked into installing an external mouse.  I found that if
> I hooked up a serial mouse to it, I could use the tp or the external
> mouse, but not both.
>
> If I had set up the external mouse, and powered up, then I was finding
> that I'd go through the boot process and discover no mouse available at
> all.  I expect I could have done some fiddling to get them both up and
> running, but an easier solution for me was to use a usb mouse.  That
> way, I never had a problem using either the tp or the usb mouse.  Both
> worked right off the bat.
>
> This was my preferred solution, because if I had hooked up a serial
> mouse, or a ps2 mouse, I usually had to power down to hook up the
> external mouse.  With a usb device, it was always hot swappable, and I
> never had to power down/up or fiddle with drivers.  It always just
> worked.  I eventually got a miniature usb 4 port hub to expand my usb
> devices, to make up for using up the only usb port on my tough book.
>
> Your needs aren't quite clear, unless I missed something.  My apologies
> if I'm belabouring the obvious.  Were you wanting to disable your tp, or
> just use an external mouse?  If the latter, then you just need to get a
> usb mouse.  There are some good wireless ones available, miniature, too,
> for laptops.  That's what I finally settled on.
>
> hth.



More information about the clug-talk mailing list