[clug-talk] Help with Nvidia and Suse?

Shawn sgrover at open2space.com
Mon Mar 14 17:52:50 PST 2005


Thanks Marcel (and Jesse).  Rebuilding the rpm database at least allowed me to 
get the right kernel source installed.

Unfortunately, my Nvidia drivers are still not working right.  I tried using 
YOU, and then sax2, with no luck.  Then I tried running the update file and 
it just runs into an error and exits.  If it helps, here's the pertinent part 
of the installer log file:

make -f scripts/Makefile.build 
obj=/tmp/selfgz4880/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv echo \#define 
NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" 
> /tmp/selfgz4880/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv_compiler.h cc 
-Wp,-MD,/tmp/selfgz4880/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/.nv.o.d 
-nostdinc -iwithprefix include -D__KERNEL__ -Iinclude  -Wall 
-Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -pipe 
-msoft-float -mpreferred-stack-boundary=2 -funit-at-a-time -funit-at-a-time  
-Iinclude/asm-i386/mach-default -O2 -fomit-frame-pointer  
-I/tmp/selfgz4880/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv -Wall -Wimplicit 
-Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses 
-Wpointer-arith  -Wno-multichar  -Werror -O -fno-common -MD  -Wsign-compare 
-Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE  -DNTRM 
-D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__-DMODULE  
-DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=7167  -DNV_UNIX   
-DNV_LINUX   -DNV_INT64_OK   -DNVCPU_X86  -UDEBUG -U_DEBUG -DNDEBUG 
-DNV_REMAP_PAGE_RANGE_5_PRESENT -DNV_CHANGE_PAGE_ATTR_PRESENT 
-DNV_PCI_DISABLE_DEVICE_PRESENT 
-DNV_CLASS_SIMPLE_CREATE_PRESENT-DNV_VMAP_4_PRESENT -DMODULE 
-DKBUILD_BASENAME=nv -DKBUILD_MODNAME=nvidia -c 
-o /tmp/selfgz4880/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.o /tmp/selfgz4880/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c/bin/sh: 
line 1: scripts/basic/fixdep: No such file or directory
   make[3]: *** 
[/tmp/selfgz4880/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.o] Error 1
   make[2]: *** 
[_module_/tmp/selfgz4880/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv] Error 2
   NVIDIA: left KBUILD.
   nvidia.ko failed to build!
   make[1]: *** [module] Error 1
   make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.

Maybe I'll try to grab the nvidia file again...  Maybe it's corrupt?

Thanks for any input.

Shawn

On Monday 14 March 2005 17:38, Marcel A. Lecker wrote:
> You might want to try:
>
> # rpm --rebuilddb
>
> ..and then try YOU to check for the updates
>
> try install again,
>
> if that fails you might try refresh the kernel and source, again via
> YOU.
>
> rpm --rebuilddb rebuilds your rpm database. I was experiencing some
> flaky update behavior and that cleared it up nicely.
>
> Just a few more ideas. Good luck
>
> Marcel



More information about the clug-talk mailing list