[clug-talk] Help with Nvidia and Suse?

Shawn sgrover at open2space.com
Sun Mar 13 02:08:40 PST 2005


Hi gang.

I'm having problems getting my nvidia drivers updated to work with the new 
kernel I just updated on my Suse 9.1 box.  I d/l'd the lastest drivers from 
Nvidia's site, and it seems to compile just fine, except it locks up the 
computer within a second or two after completing the compile.  It's a full 
lock, with no keyboard input, (though my caps lock and scroll lock lights 
start flashing at me), which forces me to do a hard boot to recover.  But the 
process didn't complete, so I still don't have the new drivers.

If it helps, here's a run down of the method I'm following:

1. exit or boot to shell prompt (init 3)
2. cd into the directory containing the nvidia file.
3. enter the command:  
 sh NVIDIA-Linux-x86-1.0-7167-pkg1.run -q --kernel-source-path=/usr/src/linux
NOTE:  The above command has never completed properly (since updating the 
kernel), so I can't continue onto the sax2 step.
4.  When the kernel compiles properly, the command 
 sax2 -m 0=nvidia
is supposed to set things up properly.

The above process worked in the past, except I was using the file 
NVIDIA-Linux-x86-1.0-6111-pkg1.run.

I did note that the kernel update was supposed to fix a problem with the 
nvidia drivers - maybe that's where the problem is coming from?  Also, it 
seems I have kernel version 2.6.5 and I think the 7167 version of the nvidia 
drivers are meant to work with 2.6.10 or newer.  Regardless running the 6111 
nvidia drivers results in the same behavior - lock up after compile.
Any tips or suggestions?  Thanks bunches.

Shawn



More information about the clug-talk mailing list